NRPN on Remote SL?
  • I am trying to set up a template to edit my Shruthi.
    Specifically I am trying to control the modulation amount for the mod sources which can only use NRPN's.
    Normal CC messages are working, NRPN's are not.

    I have the following settings on a controller:
    MSB: 0
    LSB: 34 (mod 1 amount)
    Initial value: 0
    Final value: 127

    The shruthi is giving me feedback that it is receiving something but the values are not changing. Is there something I have wrong in my settings?
  • Cool, I get to answer my own question.
    The answer was to set display type on the Remote to 0-16k

    works well now
  • hmm, I spoke too soon. This works ok on the endless encoders but the standard encoders don't work at all.
    The endless encoders are a bit flakey, though and I can't actually get a value that reflects what the shruthi gets set to
    eg - I have to set the range from 0 to 600 to get the full range of the parameter. It doesn't work at all if I set it to -63/63
  • I believe this is because the encoders are sending increment / decrement messages rather than the actual value.

  • Yes, that makes sense. Eventually after sweeping the knob back and forth I could finally get it to go from -63 to 63.
    Annoying because there is no option to control how that is going on the remote and it only works when send 14bit values is switched on.

    Do you have any thoughts why it is not working on the standard encoders (ie not endless rotaries)? Do I have the values set up correctly?