The Shruthi-1 Programmer - FINAL EDITION SOLD OUT!
  • Just put a ! round your URL if you want to show a pic, see the Textile (Help) link below…

  • I did…bit confused why it isn’t working


  • edit: yeah, does not work with imageshack, maybe switch to flickr?

    Looks OK to me… hav you a pic of the built board? You may well drop it to me via eMail daniels ät daniels-cards.de


  • it does work, you just need to click on the image itself to open it, then copy the URL.
    posting here like the following, just without the SPACE: ! http://img864.imageshack.us/img864/7316/exp.png !

  • If you want I can make more of these panels, unless of course you already have something planned. It is anodized aluminum with silk screened design.

  • do you happen to have (or be) a good source for anodized raw material?
    this question is inevitable :D

  • My source is a local (Oakland CA) guy. He provides and cuts raw aluminum for me and I take it to a guy who anodizes it.

  • wow, looking great!

    Sorry if this has been mentioned but you need firmware 0.92 to use the programmer – have you installed this?

    Cheers

  • very interested , especially with the black case , although I have a tame team that could knock up a Doepfer style aluminium case ...

    regards

    Paul
  • Hi there,
    I should have stated earlier, I am using the latest firmware and the board is V 0.7
    So I built a new pcb, using Frank’s layout. Still no joy getting the same results. As soon as I switch to prgm I get a pretty nasty modulating sound. The pots work, but looking at the screen the value keeps on flickering back to it’s original value. My 4051 are 4051BE’s.
    If the analog section works fine when in “normal” mode does this eliminate this section from being the problem?
    As always, any suggestions greatly appreciated!
    Cheers
    Al

  • Hmpf!

    Try connecting IN1 to GND and switch to Programmer Mode. Now every value should read 0. Connect +5V every value should be max. If not the Problem is on the Shruthi Side else somehow the signal from the pots does not get thru the 4051s…

    Do the values float for every of the 32 Paramaters?

  • Hi there,
    just checked that and on GND the value is solid 0 and 5v soild max. So it seems the problem is somewhere in the programmer section. All 32 parameters are floating.
    Cheers
    Al

  • Next step, try to adress the 4051s yourselves: remove the 595 and pull the B + C Adress line to GND (Pin 1 + 2) with a some K Resistor and pull the A Adress Line to +5V. So the X0 Pot of every 4051 should be selected. Now Remove the 137 and pull the Y1-Y3 Lines (Pin 14,13,12) to +5V and Y0 to GND, so the first 4051 is selected via its INH Line to the 137 and the first Bit via the ABC Adress Lines is selected. Now try tweakin the according Pot (should be OSC1 Shape). Now all Patameters should change while tweakin (might take half a second, depending on your patch…) If this works your problem is in the digital part of the Programmer Board. If not the 4051 anlaog Part works not properly… You mentioned you used 4051BE, maybe the easies way is to swap to original 4051s if handily available?

  • Ok,
    tried that. I think it is a problem with my 4051BE’s. I have one 4051N which when I do what you described works in a stable fashion (tho for some reason “parameter” not “shape” is the pot that works) When I put in my 4051BE nothing happens. I shall try and dig out some more standard 4051’s and confirm this is the problem. Thanks for the help!

  • but what would be standard here? i haven’t socketed them and also haven’t tried it yet (shame). but i have the wiring almost ready. i can try tonight.
    the ics i have here (soldered) are HCF4051BP (NXP brand) but i also have one BE. too bad i haven’t socketed them, i usually do that.

  • Interested to see what you find out…
    For me the ones that seemed to work are “MM74HC4051N“s.
    The ones that did not are “CD4051BE“s.
    This is in no way confirmed though.

  • Shame on you for not socketing!

  • yeah i know…. i’ll never do that again!

  • I’ve told that to myself, several times…

  • @rosch

    First think, then solder, else socket! (tm)
    4051s will come with the frontplate….should i throw in some of these precious, hard to come by, value by their weight in gold sockets?

  • lol, no, i always have plenty of the precision sockets. by the time i soldered this i thought it was a good idea to just solder ics directly, which i quit doing since then. now i socket everything (again).

  • i seem to have the same behaviour with my controller.
    all pots at ccw.
    now i turn eg the cutoff pot clockwise, nothing changes until almost to the end. then cutoff is set to 5, cutoff and res flicker and it stays the same when turning back. when i change the value with the menu pot i can chnage it again.

    same goes with noise and suboscillator for example.
    hmmmm…...
    man i wish i had used those sockets, at least i could test different ics then.
    could it be a soldering/wiring problem also? i’ve used one +5 and one GND wire for all pots.

  • when i crank up cutoff and res all the way, cutoff stays at 5 and res at 2. but i can change res with the menu pot while cutoff keeps jumping back to 5. also i can hear little switching noises in the headphone while cutoff is all up.
    lfo2 rate stays unchanged till about 4 o’clock (you know your vogon panel) then changes to x1, and ends at x6, the nbr 6 flickering in beat with the modulation. changes with the menu pot have no effect (jumping back)

  • because i haven’t wired the rails via the individual ribbon cables i could just turn it around. i did this with nbr1, osc1 and 2. of course all values were supposed to be maximum.
    now i also hear some noise as if you use this rainmaker instrument (don’t know if its the right term, that hollow branch with stones and whatnot in it…. sounds similar)

    nope, they’re not expected to be maximum, just in the opposite order. but i expected it though- so i turned them osc1+2 pages all up, when i disconnected conn. 1 again and put it back the right way, there was no sound anymore. rebooting helped.

  • aaaaand, as long as i’ve switched on the programmer in the system page i can hear some little noise, like the aforementioned switching noise (leises kartenmischen)

  • Interesting…I’m pretty sure the pots all use common ground and common 5v, so I don’t think that is the problem. That’s the way I wired it.
    What 4051’s are you using? I had 3 different types of 4051’s and all gave different results.
    4051BP – nothing’
    4051BE – flickering all over the place
    4051N – stable response

    I’ve ordered a few more 4051N’s, only got 1 at the moment, so I can fully test it. Will report back when they turn up.
    Cheers and good luck in the meantime!
    Al

  • thanks!
    mine are all still BP, soldered :(
    well it seems like it’s a 4051 issue. i have just one N type, that’s not too many hehe. but i’ll swap it tomorrow.
    i hoped i could have miswired the main connection, but it’s ok.
    tomorrow i’m gonna measure the pot voltages.
    but there can’t be a short to gnd, as my led is shining.

  • Yo Guys,

    id like to help you but i only got plain 4051s without any BE or BP, so i cant confirm…

    I used these or these

    BTW: Did you install the useless diode?

  • yo kogz, would youm mind tryin to termintate the A B and C adress line with something like 10K to GND and have onother try?

  • hmm well i ordered 4051bs… although im waiting on the full kit which should have the right ones. I didnt realise the suffixes affected things. : /

    I wanted them for the mezzanine filter thing which im still hoping to accomodtae in the full programmer enclosure.

  • Ok, here I come back with a new potential design for my “I hope soon to come” dual-programmer…

    Damn ! can’t manage to show the image !!! Here is the link.

    It fits on a 280 x 420 mm panel. I think I’ll buy those knobs:
    http://fr.mouser.com/ProductDetail/Eagle-Plastic-Devices/450-1C618/?qs=Xb8IjHhkxj7L2L37PKMcAA%3d%3d (black with coloured line)

    What do you think of it ?

  • @Tom

    Badass!!! I like the LFO/ENV section, but i think you need a bit TouchUp for the Mixer/Filter….


  • you first need to open the pic itself at imageshack, copy the url and paste it between exclamation marks

  • I didn’t install the useless diode. I’ll try pulling A, B and c to GND soon…

  • no wonder you have problems kogz23 . . . .

  • New PCB layout in progress:

    • reduced wire bridges to 3 instead of 11 (2 possible but unelegant)
    • easier to handle/wire connectors
    • added 4 activity LEDs
    • more conventional square layout saves space – used for some mezzaniny goodie
    • terminating adress lines for use with 4051BE/BF/Bwhatsoever Chips (will have to test this, could be removed)

    edit: dropped the activity LEDs cause auf uglyness…. same reason for 3 bridges now, i think 3 bridges of only GND on a 1 Layer board is OK

  • To fcd72:
    I searched high and low for the correct diode. Finally manged to source the correct one somewhere in the north pole. As soon as it turns up I’ll install it and see if that fixes it. Still gotta pull those addresses to ground, will do it tomorrow. Promise!

  • Yeah, I’ll test it. Just emailed you

  • Sneak Preview:

    Upper Row Right + Middle 595 Shift Register + 137 Adress Decoding, lower Row 4 4051 Analog switches. In the upper row left hand side the revised Mezzanine SMR-4 Filter Pole Switch Circuit now featuring a 4053 Analog Switch and a DuoColored LED. Oh, and the Useless Diode had to go…

    Now I go grab a Beer.

    Oh, just for fun the 3 10k terminators will have to go for something way more sophisticated …. I’m a Pro,you know?

  • i soldered 100nF caps across the supply pins of the 4051, no change

  • yo rosch, try terminating the a, b, c adress lines….

  • ok, gonna do that! thanks

  • ok, that was even more weird. i soldered the 3 10K resistors directly to the pins of 2 different ics and to the extra ground stars.
    the behaviour observed earlier was gone, now it didn’t change a value at all, just sometimes, when i actually did nothing.
    but it strangely interfered with the menu pots, also just sometimes.
    i may have damaged the 4051s, so i give it a break.
    maybe i’ll redo it on veroboard, maybe i’ll wait for the final release.

  • Hey there,
    so I tried pulling A, B and C to ground and there is no marked improvement.
    There seems to be some cross talk with the pots. For example if one parameter is not jumping around and I turn another pot the parameter will start jumping around again.
    Not to sure where to go from here. The stablest I had it is when I had the 595 and 137 out of the board, jumping it with resistors as suggested earlier.
    Cheers
    Al

  • yeah maybe it’s my 137, marked “portugal”

  • i guess ‘terminate’ means also it’s done best at the end of the lines? i’ve done it where the way was short.
    I’ve started to do it again (this time with sockets) on the experimenter’s board you recommended to me.

  • Done:

    Iwill have some samples made next week and do the new enclosure next WeekEnd….

  • Yo guys,

    i had the time to do some testing regarding the programmer problems shown up here the last few days and it turns out its more a software problem than a hardware problem. Olivier changed the CVin reading code to free up some processing power and it looks that the syncronization between adressing a specific Pot and reading the Value is broken. (Shame on me for not thoroughly testing. My fault!!)

    I can confirm the behaviour rosch and kogz23 reported with the actual 0.92 firmware and i sent an older version of the firmware to them to test. Rosch just reported now everything works as expected, so i assume the hardware side is ok (i even spotted 2 4051BEs on my Programmer ;-) )

    Now that we know where to look, Olivier promised to look at the code asap to find a fix. Thanks again a 1000 times!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion