Shuffle Modes weirdness
  • I seem to be having problems with the various shuffle modes on the MIDIpal.

    I’m assuming that when I set the shuffle, it should shuffle (it happens in every shuffle mode).. but what happens is it slooooowwwsss downnnn.. as if I am subdividing the clock.

    This happens when the clock is set to internal and any device that tries to sync with it exhibits the same behavior.

    I viewed the data coming out in MidiOX to see if maybe the durations were inaudibly short. But the notes were just crawling out.

    If I dial out any shuffle amount, the clock is perfect.

  • Confirmed. I watch the timing clock come out.. as I increase the shuffle amount, the timer starts to sputter.

  • Flashed it with the 1.1 firmware fixed it.

    http://mutable-instruments.net/static/firmware/midipal_1.1.syx

  • The parameter controlling shuffle is amt (amount). The “groove template” applied is grv

  • It didn’t matter which groove template (*grv*) I selected, as soon as a I started upping the amt parameter, the clock would sputter, and eventually slow down to 0bpm (around amt: 35-45)

    Initially thought that it was a buffering issue, but if I had the amt set to 0, I could crank the BPM all the way up and i’d get every message.

    It was weird. It was definitely not working right.

    Re-flashing the firmware fixed the issue, so I’m thinking that some sysex data reprogrammed it (unlikely, I know), or I had a feedback loop on the clock. So I just put a sysex and realtime message filter on the channel with the Midipal, and made a preset to switch between when it is the master clock or the slave clock.

    Don’t get a rash, re-flash!