Firmware updating
  • Hey guys,

    I Just try’d to update my shruthi’s firmware to 0.96. I downloaded C6, and the syx file, turned on the shruthi with s6 held down, all good. Then when i send the file the led’s turn off. and it just return’s to the splash scene for my 0.93 version after the transfer’s Finished. Any idea what im doing wrong?

    Cheers,

  • Did you configure the delay in C6 (250 ms in win, 15 (?) ticks in OS X) to the proper value?

  • That’s what happens if your Shruthi has a bootloader installed that does not recognize the sysex manufacturer ID. This ID was changed when FW 0.94 was released I think…

    I don’t know why sysex files with the old ID are not available for download too, upgrading old-bootloader-units to the latest firmware seems to work just fine (did it myself using a home-compiled 0.97 firmware beta a few days ago).

  • are ok. my firmwares 0.93 so it must have the old bootloader installed.

  • It must be a different problem. All the files I publish are compatible with the old bootloader (the new bootloader recognizes both manufacturer IDs).

  • Some MIDI interfaces don’t do sysex properly. There’s a blacklist on the MIDIBox forum which is a list of interfaces that can’t send sysex well. Make sure yours is not on the list.

    List

  • I have an alesis midi to USB cable. Which doesn’t seem to be on the list

  • Increase the delay between sysex packets. 250ms minimum, doesn’t hurt to be higher.

  • @pichenettes: My apologies, I should have tried it before guessing… :-S The files you publish do indeed work fine on older bootloaders as well.

    @theDitches: that it’s not on the list is no guarantee… What platform are you on? And is the Shruthi the only thing connected to the computer? Other midi traffic could (I guess) interfere with the update if not.

  • Normally there shouldn’t be any MIDI traffic as all forwarding Devices are suggested to stop transmissions while a SysEx Transfer is in Progress. At least this is whats recommended and what is implemented on MacOS X. I don’t know about Wind*ws or LINUX....

  • I’m on mac osx. With just the shruthi connected

  • Then it only can be a whimsy Interface….. If you run OSX and are interested in a rock Solid Interface try getting a used eMagic AMT-8 mkII (with USB).

  • Or an ISP cable.

  • Ok. Cheers for the help guys!

  • So, did you solve it?

  • No. But not shure wot else to try? I’ll try and get hold of another interface or an ISP cable I suppose

  • You’re always going to need a good MIDI interface. So best to get one of those first.

  • Release the interface, remove it and stick it in again.
    I had a lot of trouble with my ESI Midi Mate. If you have another interface try to use that.

  • Sorted!! I downloaded an app called midi toolbox and managed to send the midi file from it. I tried the sysex to start of with, and it started well but only got to the forth light by the end of the transfer. And then got stuck, but the midi file worked! Guess it must be the shady interface!!
    Duo mode is fun!!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion