Shruthi-1 midi problem
  • Hi there,
    I finaly assembled shruthi-1and it worked for like 30min and than all of the sudden midi stopped working. If i hold first button shruthi is generating sound, but is not responding for any midi keyboard ( i’ve tryied 3). It was working well, but for 30min. Any solution / similar situations ?
    Thx

  • Maybe you’ve changed the MIDI channel the unit is receiving on? (by default it is 1).

    Check that the optocoupler (6N137) is correctly inserted. You should read +5V on pin 6 of the chip at rest ; and this should drop down a bit whenever a MIDI message is sent (use the modwheel on your master keyboard to send many MIDI messages and observe the voltage drop).

  • Is the note symbol flashing on the LCD when you press keys on your keyboard?

  • Midi chanel i’ve checked many times, same with optocoupler. I will check that 6 pin, and let you know
    Thx

  • No note symbol : /

  • on pin 6 of 6n137 i have, +0,60V and nothing changes when i pressed key or pitchbend or modwheel

  • There is something wrong with the optocoupler. Check that pin 5 is continuous with ground ; and that pin 8 is at +5V

  • both are correct

  • 8 pin is 4.9V to be exact

  • I can’t buy new 6n137 untill monday, i have 6n139 would it worked also ? What could be the reason that it was working and that it stopped ?

  • I had the same problem with my first shruthi, I forgot to solder some pins on the midi connector, so contact was uncertain ….maybe you could check this

  • Hard to check now there is a LCD blocking view, but im rather shure that i solder all pins. Maybe somebody has a map with pin is going where than i could check if there is connection

  • I know that pin 2 of midi In is going to 220 resistor and that’s correct, 4 pin going to 3 pin of 6n137. How to check the rest ?

  • Schematics are here
    Pin 5 to Ground
    Pin 6 to ATMega pin 14
    Pin 7 to nothing
    and
    Pin 8 to Vcc

  • All correct both midi && 6n137, what else could be wrong ?

  • Do you get fluctuating values before the 220 on the MIDI in when moving the pitchbend or mod wheel? Since you don’t get anything on pin 6 my guess would be faulty opto coupler as the resistors rarely fail.

  • Pull the IC out. You may have a folded leg?

  • Legs are on right positions :) I will wait till monday and replace optocoupler. Meanwhile thx for involvement and support

  • I replaced optocoupler but nothing happen, still no midi :(
    What else could be wrong ?

  • Do you still see the same readings?

  • Have you tried another MIDI cable, or just three different MIDI keyboards?

  • pin 6 on 6n137 still 0.34V not 5V

  • also different Midi cables, but it was working at the beginning

  • There has to be a bad connection somewhere or a short circuit.

    Is the LCD touching any solder pads underneath?

  • Lcd is free of touching, where should i look for bad connection (area) ?

  • Are you sure the pin 5 of the 6N137 is grounded? It’s not enough to measure 0V on this pin, it needs to be continuous with another ground point. Rule out the MCU by removing it. Do you still observe the same voltage on pin5 of the optocoupler?

  • Yes pin5 i checked with other ground points also with main ground from filter.
    To be shure:
    Remove ATMEGA, than plug 5v and ground to this board, and check voltage of 5 pin optocoupler?

  • I removed ATMEGA put it back and it’s working – what happend ?
    All legs i was checking before if there were in touch with board and they ware, also all legs ware straight so no chance that they ware not in socket

  • Yes. If it’s back to +5V (with drops when there’s MIDI traffic), it’s that the MCU incorrectly pull it down, probably due to a damaged UART circuit :(

    If not, it’s certainly something around the 6N137…

  • whats UART and whay is shruthi working again ?
    :)

  • UART is the circuitry inside the ATMega644P responsible for serial communications.

  • And here it comes again, midi stopped working again like last time : {

  • I removed ATMega and checked voltage on pin 5 of 6n137 and its again 0,34V. Than i put ATMega back but 0,34V stayes.

  • Maybe there’s a weak solder point on the 10k pull-up resistor? If you remove the 6N137, do you still have 0.34V?

  • When i removed it voltage on pin5 is jumping between 1.20 – 1.24V

  • Now it event drop down to -0.04 to 0.01 and that after a while to 1.30 – 1.34 very wird

  • Pin5 is ground and should be 0V always.
    Pin6 is the logic output and should be 5V when no MIDI signal is present and be closer to 0V when MIDI signal is present.

  • With the 6N137 removed you should read a solid +5V at pin 6. Check that both ends of the 10k resistor are firmly soldered.

  • I was writing about pin6, sorry for mistake, i found that 10K resistor the one next to c10 capacitor is 222Ohm.

  • Sorry, I meant pin 6. You should read +5V at pin 6 with the optocoupler removed.

    It’s meaningless to measure a resistor in circuit.

  • So i removed all once more put it back and it’s working again, probably temorarly like always. Whats wrong how can i be shure that ATMega should be replaced ?

  • Your symptoms are not compatible with an ATMega problem ; and the fact that the problem is intermittent hints at a weak solder point on the optocoupler or around it.

  • Hmm, i change from sq80 midi to mpc midi triggering and it’s working for already more than 1h. Is it possible that ensoniq sq80 is sending sometmes some strange signal and that shruthi breakes ?

  • No. The problem you see is very low-level (electrical, bad solder point or damaged component), not something that has to deal with software or the MIDI protocol.

  • You are probably right, but it’s still working :) If it stops i will look for bad solder point, till then THX for HELP and greetings

  • So just like you said after two days of fun with shruthi, midi stopped :(
    I will try to check all solder points : /

  • Hi,
    I resolder lcd and improved all solder points below it and it works.
    Thx for a great support :)

  • great. have fun!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion